Commit d3500424 authored by jnsone11's avatar jnsone11
Browse files

add missing dependencies

parent 15919049
This diff is collapsed.
...@@ -117,6 +117,16 @@ ...@@ -117,6 +117,16 @@
"@types/react": "16.0.35" "@types/react": "16.0.35"
} }
}, },
"@types/react-redux": {
"version": "5.0.14",
"resolved": "https://registry.npmjs.org/@types/react-redux/-/react-redux-5.0.14.tgz",
"integrity": "sha512-qw2NjfDEiqWGpOTYoS55HBCdvhfC2jb/cMs0OSIDK98Uv9z2v0EDstbTlR8wiRLpbL0d3DPz2B6wxVhQ8cPw3g==",
"dev": true,
"requires": {
"@types/react": "16.0.35",
"redux": "3.7.2"
}
},
"@types/react-router": { "@types/react-router": {
"version": "4.0.21", "version": "4.0.21",
"resolved": "https://registry.npmjs.org/@types/react-router/-/react-router-4.0.21.tgz", "resolved": "https://registry.npmjs.org/@types/react-router/-/react-router-4.0.21.tgz",
...@@ -3935,6 +3945,11 @@ ...@@ -3935,6 +3945,11 @@
"resolved": "https://registry.npmjs.org/lodash/-/lodash-4.17.4.tgz", "resolved": "https://registry.npmjs.org/lodash/-/lodash-4.17.4.tgz",
"integrity": "sha1-eCA6TRwyiuHYbcpkYONptX9AVa4=" "integrity": "sha1-eCA6TRwyiuHYbcpkYONptX9AVa4="
}, },
"lodash-es": {
"version": "4.17.4",
"resolved": "https://registry.npmjs.org/lodash-es/-/lodash-es-4.17.4.tgz",
"integrity": "sha1-3MHXVS4VCgZABzupyzHXDwMpUOc="
},
"lodash.flowright": { "lodash.flowright": {
"version": "3.5.0", "version": "3.5.0",
"resolved": "https://registry.npmjs.org/lodash.flowright/-/lodash.flowright-3.5.0.tgz", "resolved": "https://registry.npmjs.org/lodash.flowright/-/lodash.flowright-3.5.0.tgz",
...@@ -5155,6 +5170,19 @@ ...@@ -5155,6 +5170,19 @@
"prop-types": "15.6.0" "prop-types": "15.6.0"
} }
}, },
"react-async-bootstrapper": {
"version": "1.1.2",
"resolved": "https://registry.npmjs.org/react-async-bootstrapper/-/react-async-bootstrapper-1.1.2.tgz",
"integrity": "sha512-E4B8dMMKw3kI9/OWMqso9P7hBvpP88iEOqjPpBBzdsgkTlMG+7yI2U2gcWef6sT9397zeBg+t0ALqxIHuT4dUQ==",
"requires": {
"react-tree-walker": "2.1.3"
}
},
"react-async-component": {
"version": "1.0.2",
"resolved": "https://registry.npmjs.org/react-async-component/-/react-async-component-1.0.2.tgz",
"integrity": "sha512-H0nT+KHADICdFgflNZ0A6+EBcExajxY8XM100tKOT5Oidhdo/0bAi26ffBhraEls4FIi8Lm4917tMq8LIWN7Qg=="
},
"react-deep-force-update": { "react-deep-force-update": {
"version": "2.1.1", "version": "2.1.1",
"resolved": "https://registry.npmjs.org/react-deep-force-update/-/react-deep-force-update-2.1.1.tgz", "resolved": "https://registry.npmjs.org/react-deep-force-update/-/react-deep-force-update-2.1.1.tgz",
...@@ -5202,6 +5230,24 @@ ...@@ -5202,6 +5230,24 @@
"lodash": "4.17.4" "lodash": "4.17.4"
} }
}, },
"react-redux": {
"version": "5.0.6",
"resolved": "https://registry.npmjs.org/react-redux/-/react-redux-5.0.6.tgz",
"integrity": "sha512-8taaaGu+J7PMJQDJrk/xiWEYQmdo3mkXw6wPr3K3LxvXis3Fymiq7c13S+Tpls/AyNUAsoONkU81AP0RA6y6Vw==",
"requires": {
"hoist-non-react-statics": "2.3.1",
"invariant": "2.2.2",
"lodash": "4.17.4",
"lodash-es": "4.17.4",
"loose-envify": "1.3.1",
"prop-types": "15.6.0"
}
},
"react-render-image": {
"version": "1.1.1",
"resolved": "https://registry.npmjs.org/react-render-image/-/react-render-image-1.1.1.tgz",
"integrity": "sha512-jYSXSOx/KYEVpyMFAJnh6HR2mHvq1OlCs5EWhZXiOK9FeqvyljkFR4vEg5jNUVNWz/dM8sSYIno0cC1PvJbTOg=="
},
"react-router": { "react-router": {
"version": "4.2.0", "version": "4.2.0",
"resolved": "https://registry.npmjs.org/react-router/-/react-router-4.2.0.tgz", "resolved": "https://registry.npmjs.org/react-router/-/react-router-4.2.0.tgz",
...@@ -5244,6 +5290,11 @@ ...@@ -5244,6 +5290,11 @@
"warning": "3.0.0" "warning": "3.0.0"
} }
}, },
"react-tree-walker": {
"version": "2.1.3",
"resolved": "https://registry.npmjs.org/react-tree-walker/-/react-tree-walker-2.1.3.tgz",
"integrity": "sha512-fO+wRVwXewrNo+89hl7bnVs72zJSBMoPspTtLkRoIDEGa/Guxdvv18kPnO78ACJz8xWA4xHzjf5Wjid+u2/FKg=="
},
"read-pkg": { "read-pkg": {
"version": "2.0.0", "version": "2.0.0",
"resolved": "https://registry.npmjs.org/read-pkg/-/read-pkg-2.0.0.tgz", "resolved": "https://registry.npmjs.org/read-pkg/-/read-pkg-2.0.0.tgz",
...@@ -5304,6 +5355,17 @@ ...@@ -5304,6 +5355,17 @@
"sourcemapped-stacktrace": "1.1.8" "sourcemapped-stacktrace": "1.1.8"
} }
}, },
"redux": {
"version": "3.7.2",
"resolved": "https://registry.npmjs.org/redux/-/redux-3.7.2.tgz",
"integrity": "sha512-pNqnf9q1hI5HHZRBkj3bAngGZW/JMCmexDlOxw4XagXY2o1327nHH54LoTjiPJ0gizoqPDRqWyX/00g0hD6w+A==",
"requires": {
"lodash": "4.17.4",
"lodash-es": "4.17.4",
"loose-envify": "1.3.1",
"symbol-observable": "1.2.0"
}
},
"regenerator-runtime": { "regenerator-runtime": {
"version": "0.11.1", "version": "0.11.1",
"resolved": "https://registry.npmjs.org/regenerator-runtime/-/regenerator-runtime-0.11.1.tgz", "resolved": "https://registry.npmjs.org/regenerator-runtime/-/regenerator-runtime-0.11.1.tgz",
...@@ -6243,6 +6305,11 @@ ...@@ -6243,6 +6305,11 @@
"integrity": "sha1-hnrHTjhkGHsdPUfZlqeOxciDB3c=", "integrity": "sha1-hnrHTjhkGHsdPUfZlqeOxciDB3c=",
"dev": true "dev": true
}, },
"typesafe-actions": {
"version": "1.1.2",
"resolved": "https://registry.npmjs.org/typesafe-actions/-/typesafe-actions-1.1.2.tgz",
"integrity": "sha512-4SparTfwBOWjegg89Ls5Ia0L6N8mXu7tb/REA5KYEfRohsLM9Uc8jtAa8bRAhtCg1cQJnvJJMjljI7dfu1JjVg=="
},
"typescript": { "typescript": {
"version": "2.6.2", "version": "2.6.2",
"resolved": "https://registry.npmjs.org/typescript/-/typescript-2.6.2.tgz", "resolved": "https://registry.npmjs.org/typescript/-/typescript-2.6.2.tgz",
......
...@@ -34,6 +34,7 @@ ...@@ -34,6 +34,7 @@
"react-render-image": "^1.1.1", "react-render-image": "^1.1.1",
"react-router-dom": "^4.2.2", "react-router-dom": "^4.2.2",
"redux": "^3.7.2", "redux": "^3.7.2",
"typesafe-actions": "^1.1.2",
"typescript": "^2.6.2", "typescript": "^2.6.2",
"whatwg-fetch": "^2.0.3" "whatwg-fetch": "^2.0.3"
}, },
...@@ -42,6 +43,7 @@ ...@@ -42,6 +43,7 @@
"@types/node": "^9.4.0", "@types/node": "^9.4.0",
"@types/node-fetch": "^1.6.7", "@types/node-fetch": "^1.6.7",
"@types/react-dom": "^16.0.3", "@types/react-dom": "^16.0.3",
"@types/react-redux": "^5.0.14",
"@types/systemjs": "^0.20.6", "@types/systemjs": "^0.20.6",
"@types/webpack-env": "^1.13.4", "@types/webpack-env": "^1.13.4",
"apollo-codegen": "^0.18.3", "apollo-codegen": "^0.18.3",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment